Produkte

VIMBA - Das SDK für AVT Kameras

VIMBA ist AVTs zukunftssicheres SDK für alle aktuellen AVT Kameras mit GigE Vision und FireWire (IEEE 1394) Interface.

Highlights:

  • VIMBA nutzt den GenICam Transport Layer (GenTL) Standard.
  • Als Schnittstelle zu Software von Drittanbietern enthält VIMBA GenTL-konforme Transport Layer Producer für IEEE 1394 (nur Windows) und GigE Vision.
  • VIMBA bietet Zugriff auf mehrere API Levels:
    • Die C API ermöglicht eine einfache Migration von älteren SDKs.
    • Die C++ API liegt als Source Code vor.
    • Unter Windows enthält VIMBA eine .NET API.
  • Ab Version 1.2.0 beinhaltet VIMBA einen Cognex-Adapter (ab Cognex 6.0).
  • VIMBA ist betriebssystemunabhängig und ermöglicht somit die Portierung von Applikationen.
  • VIMBA enthält einen Viewer.

Betriebssysteme:

  • Windows XP (nur 32-Bit)*, Windows 7(32-Bit und 64-Bit), Windows 8 (32-Bit und 64-Bit)*
  • Linux auf Standard-PCs mit Intel-kompatiblen 32-Bit und 64-Bit Prozessoren. Zurzeit ist für Linux nur der GigE Vision Transport Layer verfügbar. Getestete Distributionen:
    • Fedora 17
    • Debian 6.0.7
    • Ubuntu 12.4
  • Unterstützung von QNX und OS X ist geplant. AVTs PvAPI (nur für GigE Kameras) wurde bereits zu QNX und OS X portiert und kann genutzt werden, um AVTs GigE Kameras zu integrieren. AVT garantiert die Produktpflege für PvAPI bis 2016.
  • Auf Anfrage:
    Auf Kundenanfrage und mit nachgewiesenem kommerziellen Potenzial bietet AVT die Portierung von VIMBA zu anderen Echtzeitbetriebssystemen, zum Beispiel VxWorks. In diesen Fällen werden sämtliche Aufgabenpakete auf Projektbasis durchgeführt. Es wird vorausgesetzt, dass der Kunde Folgendes bereitstellt:
    • Ein Hardware Target (falls nötig)
    • Sämtliche benötigte Software und Lizenzen
    • Eine gut vorbereitete Tool-Chain sowie
    • Andere benötigte Hilfsmittel für die Entwicklung.

Unterstützte Kameras:

  • AVT 1394 Kameras (nur Windows)
  • AVT GigE Vision Kameras
  • VIMBA wird zukünftige USB 3 Vision Kameras unterstützen

Downloads:
Windows: VIMBA v1.2.1,  Release Notes
Linux: VIMBA v1.2.0,  Release Notes

Installationshinweis für Windows:

Es gibt keine automatische Upgradeprozedur für VIMBA Beta Versionen (v0.X.X) und VIMBA Version 1.0.X.
Wenn Sie bereits eine dieser Versionen installiert haben, deinstallieren Sie bitte VIMBA manuell über die Windows Systemsteuerung -> Programme bevor Sie spätere Releases installieren.

* Windows XP und Windows 8: Bevor VIMBA installiert wird, muss .NET Framework 2.0 SP2 oder .NET Framework 3.x installiert sein: msdn.microsoft.com/netframework/cc378097